
Homework 0: Getting Started! 
This homework will serve as a warm-up for web app development. In it, you will practice several 
skills: 

• Setting up Eclipse for Java EE development 
• Accessing a Subversion repository 
• Running a Java EE web app 

The homework will introduce you to several tools that you will be using throughout the semester: 
Eclipse, Tomcat, and Subversion (SVN). These are professional-quality tools commonly used in 
practice.  

Step 0. Test out your username/password 

You should have been issued a username and password. You will need it to complete this 
homework. 

To test your username/password, go to the following website and log in: 

https://svn.cs.memphis.edu/svn/comp7012-2014spring/examples/ 

You should see a list of files/folders. 

Step ½. Get Java (if you don’t already have it) 

You must have Java JRE version 7 (aka 1.7) or later installed on your system. If you don’t 
already have it, get it here: 

http://www.java.com/  

Simply run the executable to install. 

Step 1. Get Eclipse IDE for Java EE Developers 

First, create a folder somewhere in your user directory (e.g., on your Desktop) called jee-dev. 
(Actually, you can name it whatever you want.) 

IMPORTANT! It’s important that you pick a good spot for this folder. Moving it later will break 
things. 

Download the latest version (Kepler) of Eclipse for Java EE Developers and save it to your jee-
dev folder. Eclipse is the most widely used Integrated Development Environment (IDE) for Java. 
It includes facilities for editing, running, and debugging Java EE web apps. Get it here: 

http://www.eclipse.org/downloads/ 
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IMPORTANT! You need the version called Eclipse IDE for Java EE Developers. 

Once you’ve downloaded Eclipse, unpack the zip/tar.gz into your jee-dev folder. Thus, you 
should have an eclipse folder inside your jee-dev folder. The eclipse folder contains the Eclipse 
executable among other things. 

Next, create a folder workspace inside your jee-dev folder. Eclipse will use this folder to store 
your project files. 

Now, it’s time to fire Eclipse up. To do so, run the executable eclipse within the eclipse folder 
(i.e., with the same name). When Eclipse prompts you to select a workspace, choose the 
workspace folder you created earlier. 

Once Eclipse has launched, click the Workbench button (that looks like this: ) to open 
the Java EE perspective. 

Now set Eclipse aside for a bit, while we move on to the next step… 

Step 2. Get Tomcat 7 

Download and unpack Apache Tomcat version 7 on your machine. Tomcat is a widely used Java 
EE Web Container. You will use Tomcat as a server for your Java EE web apps. Get it here: 

 http://tomcat.apache.org/download-70.cgi 

Choose one of the Core Binary Distributions. 

IMPORTANT! Windows users, don’t choose the service-installer version. This version will 
interfere with your ability to start/stop Tomcat from within Eclipse. 

Download Tomcat and unpack the zip/tar.gz into your jee-dev folder. Thus, your jee-dev folder 
should now contain three folders: eclipse, workspace, and apache-tomcat-7.0.XX. 

You should take a look at the RUNNING.txt file within the apache-tomcat-7.0.XX folder. 
Depending on your platform, you may need to set certain environment variables. 

Step 3. Create a Tomcat server in Eclipse 

To run a web app in Eclipse, you must configure Eclipse so that it knows where a web server is 
located on your system. 

Starting from Java EE perspective, do the following to add a Tomcat server to Eclipse. 

1. Click File > New > Other… This should open a wizard-selection window. 
2. Expand Server folder, select the Server wizard, and click Next. This should start the 

Server wizard. 
3. Expand the Apache folder, select Tomcat v7.0 Server, and click Next. This should take 

you to a dialog box that asks for configuration information about the server. 
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4. To fill in the Tomcat installation directory field, click Browse. Find the apache-
tomcat-… folder, select it, and click Open. Then click Next to advance the wizard. This 
should bring up the last dialog box of the wizard. 

5. Click Finish. In the Project Explorer, you should see a Servers folder. Expand the 
folder, and you should see your Tomcat server. 

Step 4. Install the Eclipse Subversion plugin 

To download the example web app, you will need a Subversion plugin for Eclipse. Subversion is 
a tool that enables you to store your project files in a central repository and to keep track of the 
different revisions of your files. Later, you will use Subversion to turn in homework/project 
assignments and to collaborate on code with your team. 

Follow these steps to install Eclipse’s Subversive SVN Team Provider plugin: 

1. Click Help > Install New Software… This should pop up an Install window. 
2. In the Install window’s Work with: dropdown, select --All Available Sites--. 
3. In the filter field (which initially contains the words “type filter text”), enter Subversive. 

This should cause the Name/Version columns to update. Note: Eclipse may be very slow 
in updating the table. Be patient and wait for it! 

4. Check the box next to Subversive SVN Team Provider, and click the Next button. 
Click through the installation wizard by clicking Next/Finish/etc., and restart Eclipse 
when prompted. 

5. When Eclipse starts, click the Workbench button ( ) if necessary to get back 
to the Java EE perspective. 

6. Click Window > Open Perspective > Other… This should pop up a list of 
perspectives. 

7. Select SVN Repository Exploring from the list to open the perspective. Doing this 
should pop up an Install Connectors window. If you can’t get the Install Connectors 
window to appear, see the Appendix below on alternative ways to download/install the 
Connectors. 

8. From the Install Connectors window, select the version of SVN Kit (do not use 
JavaHL) that is compatible with SVN 1.6.x, and click Finish. This should cause an 
installation wizard to pop up. If this step does not work (e.g., because of a network 
error), see the Appendix below on alternative ways to download/install the Connectors. 

9. Click through the installation wizard by clicking Next/Finish/etc., and restart Eclipse 
when prompted. When Eclipse restarts, you should be back at the SVN Repository 
Exploring perspective. The left column of the main Eclipse window should have an 
SVN Repositories view instead of the usual Project Explorer view. 

Step 5. Checkout the example web app 

To download the example web app, you’ll need to use Subversion to “checkout” a copy of the 
example source code. 

Go to the SVN Repository Exploring perspective (see Step 4), and perform the following steps 
to do the checkout: 
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1. At the top of the SVN Repositories view is a New Repository Location button—click 
it. This should open a New Repository Location window with fields for you to fill in. 

2. Fill in the fields as follows, and click Finish. 
• URL: https://svn.cs.memphis.edu/svn/comp7012-2014spring/examples/ 
• User and Password: enter your username and password 
This should add the repository to the SVN Repositories view. You may get a message 
about “master password” and/or “password recovery”. This is your OS trying to help you 
keep track of your passwords. Whatever option you choose is probably fine. 

3. Expand the contents of the repository by clicking the triangle. You should see a joker-
simple folder. 

4. Expand the joker-simple folder, and you should see three folders: trunk, branches, and 
tags. 

5. Right click on trunk, and select Check Out. This should cause a copy of the joker-
simple project to download. 

6. Switch to the Java EE perspective (by clicking the button that looks like  near 
the upper right of the Eclipse window). If you see the joke-simple project in the Project 
Explorer, the checkout was successful. 

7. The project will be broken initially, indicated by a small red ×. To fix it, right click on 
the joke-simple project in the Project Explorer, and select Maven > Update Project… 
An Update Maven Project window should pop up. Click OK. The red × should 
disappear. 

Step 6. Run the web app 

To run the web app, perform the following steps from the Java EE perspective. 

1. Right-click on the joke-simple project in the Project Explorer, and then click Run As > 
Run on Server. This should bring up the Run on Server wizard. 

2. Click Finish to launch the web app. 

Step 7. One last thing to fix 

For Maven to work properly in the future, you must rebuild its repository index: 

1. Click Window > Show View > Other… This should pop up a Show View window. 
2. Expand the Maven folder, and select Maven Repositories. Click OK. A Maven 

Repositories view should appear near the bottom of the Eclipse window. 
3. In the Maven Repositories view, expand Global Repositories item to reveal the central 

item. 
4. Right-click on central, and select Rebuild Index. This should pop up a confirmation 

dialog; click OK. This should cause Eclipse to rebuild its Maven index. Note: Eclipse 
may be very slow at rebuilding the index. It may take on the order of minutes. 
Furthermore, the progress (bottom right corner of Eclipse window) may sit at 0% for a 
very long time. Once it completes, you should be able to expand central and see many 
items, such as abbot, acegisecurity, etc. 
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Submitting 

To receive credit for this homework, you must demonstrate that you can run the web app at the 
start of class on the day the homework is due. 

Appendix: Alternative ways to install the Subversive SVN 
Connectors 

Way #1: Tell the Install New Software window where to find the plugin 

With this approach, rather than leaving it to Eclipse to prompt you with the Install Connectors 
window, we take the bull by the horns, and initiate installing the Connectors ourselves. 

1. In Eclipse, click Help > Install New Software. This should cause an Install window to 
appear. 

2. Click the Add button at the far right of Work with field. This should pop up an Add 
Repository window. 

3. In the window, enter this URL in both the Name and Location fields: 
http://community.polarion.com/projects/subversive/download/eclipse/3.0/kepler-site/  
This should cause the URL to be added to the Work with drop-down list. 

4. Select the URL from the Work with drop-drown list. If everything is working, you 
should see a Subversive SVN Connectors entry. 

5. Expand the Subversive SVN Connectors entry, and check the Subversive SVN 
Connectors plugin and the SVNKit 1.3.8 plugin. 

6. Continue through the wizard to install the plugins, finally restarting Eclipse. 

Way #2: Manually download the plugins 

If Eclipse is, for whatever reason, unable/unwilling to download the plugin, we can always just do 
it ourselves.  

1. In your web browser, open this URL: 
http://community.polarion.com/projects/subversive/download/eclipse/3.0/builds/  
You should see a list of zip files. 

2. Choose the newest zip file, and download it (e.g., saving it on your Desktop). At the time 
of writing, the newest zip was Subversive-connectors-allplatforms-3.0.4.I20131116-
1700.zip. 

3. Now, open Eclipse, and click Help > Install New Software. This should cause an Install 
window to appear. 

4. Click the Add button at the far right of Work with field. This should pop up an Add 
Repository window. 

5. Click the Archive… button. This should cause a file chooser to appear. 
6. In the file chooser, select the zip file that you downloaded a moment ago. This should fill 

in the Location field with the path to the zip file. 
7. Fill in the Name field however you like, and click OK. This should cause a new entry to 

be added to the Work with drop-down list. 
8. Select the new entry from the Work with drop-drown list. If everything is working, you 

should see Subversive SVN Connectors displayed in the table. 
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9. Expand the Subversive SVN Connectors entry, and check the Subversive SVN 
Connectors plugin and the SVNKit 1.3.8 plugin. 

10. Continue through the wizard to install the plugins, finally restarting Eclipse. 


